Twitter Subscribe to PHP Blog RSS Feed Email RSS

FreeBSD下从ports安装Gnome2.22

添加评论 2008年10月1日
可以转载, 但必须以超链接形式标明文章原始出处和作者信息及版权声明

准备工作:

1.更新ports

2.重新编译内核

(一) 安装 Xorg
注:要完整地编译Xorg至少要4GB的剩余磁盘空间
ports: [x11/xorg]
#cd /usr/ports/x11/xorg
#make install clean
对于 Xorg 7.3 这个版本,可以不需要任何的配置文件就能运行:
%startx

若不能启动 X11, 也许是默认的配置文件不适合你机器的配置,这时候就需要手工配置 X11。
# Xorg -configure         //生成配置文件 xorg.conf.new
# Xorg -config xorg.conf.new    //测试配置文件是否能正常启动X11

发现并解决问题可以参考的日志文件为 /var/log/Xorg.0.log,一切准备妥当后,就可以把配置文件放到公共的目录中了:
#cp xorg.conf.new /etc/X11/xorg.conf     //这个位置也可以是/usr/local/etc/X11/xorg.conf

//Xorg 7.3_2 以后能自动配置 Intel915 系列显卡的宽屏显示问题,对于之前的版本,如果无法通过配置文件解决问题,需要用到 sysutils/915resolution

#cd /usr/ports/sysutils/915resolution
#make install clean

添加以下内容到 /etc/rc.conf

i915resolution_enable=”YES”
i915resolution_modes=”49″
i915resolution_width=”1280″
i915resolution_height=”768″
//modes可以通过运行”915resolution -l”得到的显示模式参考填写。

#/usr/local/etc/rc.d/915resolution start

(二)安装gnome2-lite

#cd /usr/ports/x11/gnome2-lite
#make install clean

//部分编译错误的处理

“Checing for DBUS… configure:error:
“Package requirements(dbus-1 >=1.1.2) were not met:
“Requested ‘dbus-1 >=1.1.2’ but version of dbus is 1.0.2

“Stop in /usr/ports/sysutils/system-tools-backends
“Error code 1

#portupgrade dbus

“Package requirements(pixman >=0.10.0) were not met:
“Requested ‘pixman >=0.10.0’ but version of dbus is 0.9.6

#portupgrade pixman

“Package requirements(hal-storage >=0.5.8_1) were not met:
“Requested ‘hal-storage >=0.5.8_1’ but version of hal-storage is 0.5.8

#portupgrade hal         //update hal-0.5.8.20070909 to hal-0.5.11

同样的错误提示,更新:libvolume_id-0.75 to libvolume_id-0.77

“machine.h:60:error:redefinition of typed of ‘cpumask_t’
“/usr/src/sys/sys/types.h:146:error:previous declaration of ‘cpumask_t’ was here

“Stop in /usr/ports/sysutils/lsof/work/lsof-4.81A.freebsd/lib
“…Error Code 1

重新编译系统 FreeBSD 7.0-Release,并且更新到 FreeBSD 7.0-Release-p4

#cd /usr/ports/sysutils/lsof
#make clean
#make install clean

然后回到 /usr/ports/x11/gnome2-lite 接着编译安装

“gtar-1.20_1 cannot install: unknow AUTOCONF version: 261
“Stop in /usr/ports/archivers/gtar
我当前的atuoconf版本为2.62

#cd /usr/ports/archivers/gtar
#vi Makefile
将配置文件制定的 AUTOCONF 版本改为262
USE_AUTOTOOLS=autoconf:262:env

评论